Neat Legacy Support Community

Welcome to Neat's Legacy Support Community.
Here you will find questions and answers from customers just like you!


Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Legacy 5.4, need 5.7

Linda Hagedorn - Dec 30, 2016 11:18AM

Hi.

I need the URL to upgrade my legacy 5.4 to the latest/last supported legacy version. I think it's 5.7.

I've elected to remain on the legacy version. I have 5.4, and the 'sync popup' won't stop popping up. I read it can be turned off in 5.7, so I need 5.7 to make the popup stop.

Thanks, Linda

3 Community Answers

Lee M. Dec 30, 2016 11:39AM The Neat Company Agent

Linda—

You can download and install the Neat 5.7 update file here: http://www.neat.com/helpcenter/windows-v5-update/. Once you have updated to version 5.7, enter your Neat login credentials in the sign in window to prevent it from popping up constantly.

rated: -1
Up Down
MelissaBrett May 15, 2017 09:52AM
Is this link for the upgrade legacy software gone? My computer crashed, had the database backed up, but the software CD was an old version, and I need to upgrade to the last legacy version in order to import the backup. Please help
rated: 0
Up Down
Lee M. May 16, 2017 09:12AM The Neat Company Agent

Melissa—

What version do you have installed currently? If you are using Neatworks v4, you can upgrade using the steps here: https://neat.desk.com/customer/en/portal/articles/2734052-upgrading-to-neat-5

rated: 0
Up Down

Post Your Public Answer

Your name (required)
Your email address (required)
Answer (required)