Neat Legacy Support Community

Welcome to Neat's Legacy Support Community.
Here you will find questions and answers from customers just like you!


Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Compatibility with Operating System Upgrade?

Kelley - Nov 22, 2016 11:50AM

Hi, I currently use Neat Desk version 4.0.3 on my Mac which is running OS X Lion 10.7.5 & I need to upgrade my Operating System to macOS Sierra. I am just checking to see if this Version of Neat will be compatible with OS Sierra..... Please help. Thank you very much!

4 Community Answers

Lee M. Nov 22, 2016 12:59PM The Neat Company Agent

Kelley,

Version 4.0.3 is out-of-date, and may not be compatible with Sierra. You can download the latest versions of Neat here: http://www.neat.com/support/download-neat-software/.

rated: -4
Up Down
Tifany Mar 13, 2017 09:10AM
I need to download neat but I'm not sure which Neat software is compatible to Mac OS Sierra
rated: -1
Up Down
Patrick May 22, 2017 09:39AM
The link you provided above for legacy software don't work.
rated: -2
Up Down
Lee M. May 23, 2017 09:40AM The Neat Company Agent

Patrick—

The steps to download are available here: https://neat.desk.com/customer/portal/questions/16962645-download-mac-legacy-software

rated: -2
Up Down

Post Your Public Answer

Your name (required)
Your email address (required)
Answer (required)
Ask a Question